[xquery-talk] incomplete results

Cindy Girard clm6u at virginia.edu
Wed Dec 1 10:06:21 PST 2004

I thought I had the if statements correct b/c the query says it's
looking for the @n attribute, but then it doesn't return it.

However, as an experiment, I took out all the if statements and had it
return the @n attribute, whether it actually had it or not - and it
worked. So, to clarify for my own benefit, xquery isn't checking the
existence of @n, it just returns it if it's there, and if it's not, it
ignores it. Is that right? I was expecting an error if I tried to
return an attribute that wasn't there.


WM> Hi Cindy,

WM> as you are obviously passing this to eXist's eval(), I just thought it
WM> might be a bug in my code, so I tried each of the three queries you
WM> generated. However, I always get the "n" attribute returned correctly.
WM> Are you sure your if statement selects the right alternative? The last
WM> one doesn't use the @n attribute.

WM> Wolfgang

>> Hi.
>>   I have a query that is testing for a specific id attribute, then
>>   returning an extra attribute in the results. It appears
>>   to be working, except that the additional attribute (the 'n' att),
>>   just doesn't appear in the results. No error is issued anywhere,
>>   it's just not there.
>>   Any ideas what I can be doing wrong or how to better troubleshoot
>>   it? The code is listed below.
>>   Thanks.
>> (  and thanks to Michael, Jeni, and David Sewell for helping me fix my
>>   atrocious syntax problems. )
WM> _______________________________________________
WM> talk at xquery.com
WM> http://xquery.com/mailman/listinfo/talk

- Cindy 

More information about the talk mailing list